Skip to content

Docker container reboot loop with unauthenticated SOCKS config #81

Description

@foghorn

With the latest Docker build that was released, the unauthenticated SOCKS5 proxy configuration no longer works. The container continually reboots and emits the following log message:

Error: REQUIRE_AUTH is true, but PROXY_USER and PROXY_PASSWORD are not set. The application will now exit.

Here's my Docker run command I'm using:

docker run -d --name vpn-socks5
--network=container:vpn
--restart=unless-stopped
serjs/go-socks5-proxy

I tried adding --REQUIRE_AUTH=false but that errored stating that it was not a supported configuration parameter.

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    No labels
    No labels

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions