Repository navigation
[Bug]: tuning tx audiolevel with beacons=on results in server crash #980
Copy link
Copy link
Closed
Labels
bug 🪲Something isn't workingSomething isn't working
Description
Activity
Can't reproduce the bug, nevertheless I fixed a bug, showed in your log :-)
@dk5sm any news regarding this?
2025-08-31 05:21:24 [warning ] [RIGCTLD] Error sending command [m] to rigctld: 'NoneType' object has no attribute 'recv' 2025-08-31 05:21:24 [warning ] Error getting ALC: 'chk_vfo' 2025-08-31 05:21:24 [warning ] Error getting vfo: 'chk_vfo' 2025-08-31 05:21:24 [warning ] Error getting strength: 'chk_vfo' 2025-08-31 05:21:24 [warning ] Error getting vfo: 'chk_vfo' 2025-08-31 05:21:24 [warning ] Error getting RF power: 'chk_vfo' 2025-08-31 05:21:24 [warning ] Error getting vfo: 'chk_vfo' 2025-08-31 05:21:24 [warning ] Error getting SWR: 'chk_vfo' 2025-08-31 05:21:24 [warning ] Error getting vfo: 'chk_vfo' Killed running instance with PID: 4551We have to stop rigctld polling before killing rigctld
2025-08-31 05:20:59 [warning ] [SHUTDOWN] stopping schedule manager.... 2025-08-31 05:21:00 [warning ] [SHUTDOWN] schedule manager stopped 2025-08-31 05:21:00 [debug ] Event: ev={'freedata_server': 'stopped'} 2025-08-31 05:21:00 [info ] Stopping rigctld service Killed running instance with PID: 2419 2025-08-31 05:21:00 [warning ] [RIGCTLD] Error sending command [m] to rigctld: [Errno 32] Broken pipe2025-08-31 05:21:27 [info ] Attempting to start rigctld using binary found at: /home/administrator/freedata/FreeDATA-hamlib/bin/rigctld 2025-08-31 05:21:27 [info ] Successfully executed rigctld args=['-m', '3073', '-r', '/dev/ttyUSB0', '-s', '115200', '-p', '/dev/ttyUSB0', '-P', 'RIG', '-D', 'NONE', '--set-conf', 'dtr_state=OFF', '--set-conf', 'data_bits=8', '--set-conf', 'stop_bits=1', ''] 2025-08-31 05:21:27 [info ] [RIGCTLD] Connection attempt 1/60 to 127.0.0.1:4532 2025-08-31 05:21:27 [warning ] [RIGCTLD] Attempt 1 failed: [Errno 111] Connection refused 2025-08-31 05:21:27 [info ] [EXPLORER] Data pushed successfully 2025-08-31 05:21:27 [info ] Running BeaconCommand 2025-08-31 05:21:27 [debug ] [MDM] TRANSMIT delay=50 mode=signalling 'AppContext' object has no attribute 'radio_manager' 2025-08-31 05:21:27 [info ] [DatabaseManagerBeacon]: Deleted 0 beacons older than 2 days 1756617687.500702 1756617627.500702 missing_bursts None 2025-08-31 05:21:28 [info ] [RIGCTLD] Connection attempt 3/60 to 127.0.0.1:4532 2025-08-31 05:21:28 [info ] [RIGCTLD] Connection attempt 2/60 to 127.0.0.1:4532 2025-08-31 05:21:30 [info ] [RIGCTLD] Connected to rigctld at 127.0.0.1:4532 2025-08-31 05:21:30 [info ] [RIGCTLD] Connected to rigctld at 127.0.0.1:4532 1756617707.506012The key might be this error:
'AppContext' object has no attribute 'radio_manager'It occurs, if we have the beacon running and then changing tx audio level. After server restart, radio_manager isnt initialized.
Reacted by Stefan DK5SMLooks like you fixed it with the latest code change!
Metadata
Metadata
Assignees
Labels
bug 🪲Something isn't workingSomething isn't working
Projects
- StatusShow more project fieldsDone
FreeDATA Version
0.17.3-beta (develop)
What operating system are you using?
Ubuntu
Operating System Version
24.04 LTS Server
Architecture
x64
Area of problem
Server - General
Describe the bug
Tuning the tx audiolevel (using Tune-widget) directly after FD server starts is possible without issues.
Tuning tx audio level while beacon is activated, causes the FD to get unresponsive: waterfall stops and does not come back after modem has restarted. Reloading GUI makes waterfall a white window. Hitting CQ for example does not lead to radio tx - simply nothing happens. Afaik only a full FD restart can fix that.
Seems to make no difference whether "Auto RX level" feature is activeted in settings or not.
To Reproduce
Expected behavior
should work as before ;-)
Screenshots
No response
Log Files
fd server crash after tx level change.txt
Additional context
No response