Skip to content

[Bug]: tuning tx audiolevel with beacons=on results in server crash #980

Description

@dk5sm

FreeDATA Version

0.17.3-beta (develop)

What operating system are you using?

Ubuntu

Operating System Version

24.04 LTS Server

Architecture

x64

Area of problem

Server - General

Describe the bug

Tuning the tx audiolevel (using Tune-widget) directly after FD server starts is possible without issues.
Tuning tx audio level while beacon is activated, causes the FD to get unresponsive: waterfall stops and does not come back after modem has restarted. Reloading GUI makes waterfall a white window. Hitting CQ for example does not lead to radio tx - simply nothing happens. Afaik only a full FD restart can fix that.

Seems to make no difference whether "Auto RX level" feature is activeted in settings or not.

To Reproduce

  1. start server
  2. change TX level slightly (via Tune-widget) - works ok and waterfall comes back after modem reload
  3. switch on beacon
  4. change tx level again and fd server crashes as decribed above

Expected behavior

should work as before ;-)

Screenshots

No response

Log Files

fd server crash after tx level change.txt

Additional context

No response

Activity

  1. moved this to Backlog in FreeDATAon Jun 1, 2025
  2. DJ2LS commented on Jun 1, 2025

    @DJ2LS
    Owner

    Can't reproduce the bug, nevertheless I fixed a bug, showed in your log :-)

  3. moved this from Backlog to In progress in FreeDATAon Jun 1, 2025
  4. DJ2LS commented on Jun 6, 2025

    @DJ2LS
    Owner

    @dk5sm any news regarding this?

  5. DJ2LS commented on Aug 31, 2025

    @DJ2LS
    Owner
    
    2025-08-31 05:21:24 [warning  ] [RIGCTLD] Error sending command [m] to rigctld: 'NoneType' object has no attribute 'recv'
    2025-08-31 05:21:24 [warning  ] Error getting ALC: 'chk_vfo'
    2025-08-31 05:21:24 [warning  ] Error getting vfo: 'chk_vfo'
    2025-08-31 05:21:24 [warning  ] Error getting strength: 'chk_vfo'
    2025-08-31 05:21:24 [warning  ] Error getting vfo: 'chk_vfo'
    2025-08-31 05:21:24 [warning  ] Error getting RF power: 'chk_vfo'
    2025-08-31 05:21:24 [warning  ] Error getting vfo: 'chk_vfo'
    2025-08-31 05:21:24 [warning  ] Error getting SWR: 'chk_vfo'
    2025-08-31 05:21:24 [warning  ] Error getting vfo: 'chk_vfo'
    Killed running instance with PID: 4551
    
    
  6. DJ2LS commented on Aug 31, 2025

    @DJ2LS
    Owner

    We have to stop rigctld polling before killing rigctld

    
    2025-08-31 05:20:59 [warning  ] [SHUTDOWN] stopping schedule manager....
    2025-08-31 05:21:00 [warning  ] [SHUTDOWN] schedule manager stopped
    2025-08-31 05:21:00 [debug    ] Event:                         ev={'freedata_server': 'stopped'}
    2025-08-31 05:21:00 [info     ] Stopping rigctld service
    Killed running instance with PID: 2419
    2025-08-31 05:21:00 [warning  ] [RIGCTLD] Error sending command [m] to rigctld: [Errno 32] Broken pipe
    
    
  7. DJ2LS commented on Aug 31, 2025

    @DJ2LS
    Owner
    
    2025-08-31 05:21:27 [info     ] Attempting to start rigctld using binary found at: /home/administrator/freedata/FreeDATA-hamlib/bin/rigctld
    2025-08-31 05:21:27 [info     ] Successfully executed rigctld  args=['-m', '3073', '-r', '/dev/ttyUSB0', '-s', '115200', '-p', '/dev/ttyUSB0', '-P', 'RIG', '-D', 'NONE', '--set-conf', 'dtr_state=OFF', '--set-conf', 'data_bits=8', '--set-conf', 'stop_bits=1', '']
    2025-08-31 05:21:27 [info     ] [RIGCTLD] Connection attempt 1/60 to 127.0.0.1:4532
    2025-08-31 05:21:27 [warning  ] [RIGCTLD] Attempt 1 failed: [Errno 111] Connection refused
    2025-08-31 05:21:27 [info     ] [EXPLORER] Data pushed successfully
    2025-08-31 05:21:27 [info     ] Running BeaconCommand
    2025-08-31 05:21:27 [debug    ] [MDM] TRANSMIT                 delay=50 mode=signalling
    'AppContext' object has no attribute 'radio_manager'
    2025-08-31 05:21:27 [info     ] [DatabaseManagerBeacon]: Deleted 0 beacons older than 2 days
    1756617687.500702
    1756617627.500702
    missing_bursts None
    2025-08-31 05:21:28 [info     ] [RIGCTLD] Connection attempt 3/60 to 127.0.0.1:4532
    2025-08-31 05:21:28 [info     ] [RIGCTLD] Connection attempt 2/60 to 127.0.0.1:4532
    2025-08-31 05:21:30 [info     ] [RIGCTLD] Connected to rigctld at 127.0.0.1:4532
    2025-08-31 05:21:30 [info     ] [RIGCTLD] Connected to rigctld at 127.0.0.1:4532
    1756617707.506012
    
    
  8. DJ2LS commented on Aug 31, 2025

    @DJ2LS
    Owner

    The key might be this error:
    'AppContext' object has no attribute 'radio_manager'

    It occurs, if we have the beacon running and then changing tx audio level. After server restart, radio_manager isnt initialized.

  9. added a commit that references this issue on Aug 31, 2025
  10. linked a pull request that will close this issuev0.17.7 #996on Aug 31, 2025
  11. moved this from In progress to Done in FreeDATAon Aug 31, 2025
  12. dk5sm commented on Aug 31, 2025

    @dk5sm
    CollaboratorAuthor

    Looks like you fixed it with the latest code change!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    bug 🪲Something isn't working

    Projects

    • Status
      Done

    Milestone

    No milestone

    Relationships

    None yet

    Development

    No branches or pull requests

    Issue actions